Pages: [1]   Go Down
Author Topic: iPhone woes!!!  (Read 31882 times)
Posts: 1

« on: November 18, 2009, 08:11:53 am »

I have an iPhone 3G, 8GB, which came new out of the box with the following identifiers...

Software version: 2.2.1 (5H11)
Carrier: AT&T 3.1
Model number: MB046LL
Modem firmware: 2.30.03

In the last several weeks I have not installed anything new on it, nor done any updates of any kinds, nor made any configuration changes.

A few days ago it began giving me problems when trying to make calls.  The carrier signal shows full bars - until I try to make a call.  As soon as I initiate a call the signal bars immediately disappear and I get the message, "Call Failed."  After 20-30 seconds, the bars reappear (full).  This behavior is consistent 100% of the time for the last 3 days, along with intermitten freezing and rebooting on its own.

I have power-cycled the phone and turned 3G on/off many times to try to fix the issue (or at least get the issue to show signs of change for process of elimination).  I have also driven around in a 60-65 mile radius with the phone, power-cycling it every so often (and turning 3G on/off) in hope that causing it to connect to a different cell tower would show some improvement (no luck there).

So I decided to restore the phone (regular restore and hard restore).  I have tried the restores several times on multiple different computers (Windows XP, Vista and 7) and versions of iTunes (from v7.x through v8.x).  This is where things get strange.

No matter how many computers I try the restore from, and no matter which version of iTunes I use prior to v9, the behavior, which is consistent, is as follows.

If I connect the phone to a computer, with the phone powered up and not in DFU mode, and click "Update" in iTunes, iTunes tells me that my phone already has the latest available software (2.2.1).  However...

If I connect the phone to a computer, with the phone powered up and not in DFU mode, and click "Restore," iTunes tries to download an incorrect IPSW file (2.0.2).  It gives me the agreement to accept for v2.0.2, and when I agree, it downloads the file [iPhone1,2_2.0.2_5C1_Restore.ipsw], which installs fine, and the device operates fine with the exception that the call problem described above still exists.

If I connect the phone to a computer, with the phone in DFU mode, iTunes tells me it has detected a phone in restore mode and that it needs to check with Apple to identify the phone.  I allow iTunes to do the check, then tell it to go ahead and do the restore, which, again, tries to install 2.0.2.

I then tried other restores from the various computers and various versions of iTunes cited above (both with the phone in DFU mode and not in DFU mode) - using shift + restore button in iTunes to manually select the correct IPSW file [iPhone1,2_2.1.1_5H11_Restore.ipsw], which does not install.  It appears to go through the entire installation process, all the way up to verifying installed firmware, then fails with a message in the error logs that it cannot downgrade the baseband, and iTunes throws error 1013.

So today I installed iTunes 9 and connected the phone in DFU mode.  iTunes told me that a new software update v3.1.2 7D11 is available.  I allowed iTunes to install this update, which installed fine and DID fix the call problem described above.  I then used blackra1n to... eh... "enhance" my iPhone experience, which worked like a charm.  HOWEVER, now several of the apps that previously ran fine before all the above-described problems started now crash.  Some examples (of apps and messages in the Crash logs) are:

Mobile Terminal (Dyld Error Message: Library not loaded: /System/Library/PrivateFrameworks/Apple80211.framework/Apple80211.  Referenced from: /private/var/stash/Applications.BxqixM/  Reason: image not found.  Dyld Version: 149).

StumblerPlus (Dyld Error Message: Library not loaded: /System/Library/PrivateFrameworks/Apple80211.framework/Apple80211.  Referenced from: /private/var/stash/Applications.BxqixM/  Reason: image not found.  Dyld Version: 149).

These are only a couple of examples of apps that used to run fine prior to the 3.1.2 update.  Several other apps are now crashing, which used to run fine.  Also, several other apps that used to run fine now crash without generating any crash logs (Phyl is one example).  Other apps that used to work now only "sort of" work.  Veency, for example, appears to work, and I can connect to it from a remote host; however, as soon as I connect to my device, the device freezes up and the app icons randomly disappear, although the icon text remains; I have to respring to recover.

Help!  I was warned repeatedly against buying an iPhone and I guess this is what I get for not listening.  However, since I made the purchase and am stuck with this thing, can anyone give me any insight as to how to either (A) get previously-working apps to work again on 3.1.2 7D11, or (B - preferred) force my phone device back to firmware 2.2.1 5H11?

Thanks in advance!
« Last Edit: November 24, 2009, 08:29:12 pm by Echelon » Logged
Pages: [1]   Go Up
Jump to: